.NET Framework 4.8 Instal·ladors fora de línia Enllaços de descàrrega directa

.NET Framework és el nucli de desenvolupament de Microsoft. Tant si sou usuari de Windows com si desenvolupeu Visual Studio, necessitareu .NET Framework al vostre ordinador. Si utilitzeu la versió més recent de Windows 10 de la versió 1803, tindreu instal·lat .NET Framework 4.7.2 per defecte.

Molt probablement, la versió 1809 de Windows 10 vindrà amb .NET Framework 4.8. Si voleu instal·lar-lo en qualsevol altra versió de Windows 10, compartirem els enllaços de descàrrega directa als instal·ladors de .NET Framework 4.8 d’aquest article. Però primer és important revisar les novetats, tot i que no són rellevants si només sou usuari i no desenvolupador, i els requisits del sistema i, a continuació, enumerarem els enllaços de baixada. Resum ràpid amagar-se 1 Noves funcions i millores 2 Problemes encara no solucionats 2.1 Punts morts i condicions de carrera 2.2 DPI alt 3 .NET Core vs. .NET Framework 4.8 4 Requisits i sistemes operatius admesos 5 Instal·lació de .NET Framework 4.8 6 Descarregueu .NET Framework 4.8

Noves funcions i millores

Hi ha força millores i millores noves en el nou marc. Com que encara està en desenvolupament, no podem dir amb certesa si s’afegiran o no noves funcions a aquesta versió.

Algunes de les noves funcions i millores de .NET Framework 4.8 inclouen el següent:

  • Millores d’accessibilitat per a Windows Forms
  • Propietat SelectionTextBrush
  • ZLib actualitzat
  • Rendiment millorat

Problemes encara no solucionats

Encara hi ha problemes i errors a .NET Framework 4.8 que cal corregir.

Punts morts i condicions de carrera

Moltes de les biblioteques bàsiques de .NET encara ofereixen condicions de cursa i de bloqueig. El bloqueig es produeix amb trucades simultànies a nous mètodes dinàmics i es produeix un punt mort quan es crida la funció Dispose a un EventSource a CLR.

DPI alt

Les configuracions de diversos monitors van causar problemes amb els DPI. Cal calcular l’escala i la resolució de la resolució, cosa que encara suposa un repte,

.NET Core vs. .NET Framework 4.8

Bàsicament, .NET Framework es va dissenyar per desenvolupar aplicacions en i per a Windows. Altres tecnologies de tercers, com ara el port Mono i Xamarin. NET Framework per a dispositius mòbils i Linux, respectivament.

Ara Microsoft està construint un framework .NET Core que tindrà la capacitat de suportar totes les plataformes, incloses Windows, Linux, Android, iOS, etc. Això s’assemblarà més a la portabilitat de Java.

Requisits i sistemes operatius admesos

.NET Framework no es pot instal·lar a tots els sistemes operatius de Windows, però només s’admeten un grapat de versions de Windows 10. Aquí teniu la llista de versions de Windows 10 i Windows Server compatibles amb .NET Framework 4.8.

  • Actualització de Windows 10 d'abril de 2018
  • Actualització de Windows 10 Fall Creators
  • Actualització de Windows 10 Creators
  • Actualització de l'aniversari de Windows 10
  • Windows Server versió 1709
  • Windows Server 2016

Instal·lació de .NET Framework 4.8

Aquesta versió de .NET Framework 4.8 Early Access substituirà qualsevol instal·lació existent de .NET Framework 4 i posterior a la vostra màquina.

Un cop instal·leu la versió més recent de .NET Framework 4.8, totes les aplicacions de .NET Framework 4 i posteriors a la vostra màquina s’executaran per defecte amb les noves versions d’accés anticipat de .NET Framework.

La instal·lació del framework és força senzilla. Després de descarregar l'instal·lador fora de línia des dels següents enllaços, executeu l'executable i seguiu les instruccions.

Després d’extreure els fitxers i acceptar els seus termes i condicions, apareixerà la finestra següent.

net framework 4 8 instal·lador

De la mateixa manera, es pot instal·lar l'instal·lador web de .NET Framework 4.8.

Instal·lació del paquet de desenvolupadors de .NET Framework 4 8

Descarregueu .NET Framework 4.8

descarregar Instal·lador web de .NET Framework 4.8

descarregar Instal·lador fora de línia de .NET Framework 4.8

descarregar Paquet de desenvolupadors de .NET Framework 4.8 + la resta de descàrregues

El paquet de desenvolupadors consta de tres components. Si voleu instal·lar-los tots tres, inclòs el framework, és possible que preferiu descarregar el paquet de desenvolupador en lloc d’instal·lar els components un per un.

  • Paquet d'orientació .NET 4.8
  • .NET Framework 4.8
  • SDK de .NET Framework 4.8

Si voleu que els missatges d'error es tradueixin al vostre idioma, podeu descarregar i instal·lar paquets d'idioma de .NET Framework 4.8 per a l'idioma que vulgueu. S'admeten 23 idiomes. Els més populars inclouen alemany, francès, xinès, italià, japonès, portuguès i rus.

Baixeu paquets d'idiomes de .NET Framework 4.8