Pale Moon 29.2.0 ja no admet les extensions de Firefox heretades que no es porten

Quan Mozilla va canviar del seu sistema complementari heretat a WebExtensions, les forquilles de Firefox, com ara Pale Moon, van augmentar els usuaris que volien continuar utilitzant extensions que el nou sistema de Mozilla ja no admetia. No totes les extensions funcionaven, però sí, i els usuaris podien continuar utilitzant aquestes extensions.

El llançament de Pale Moon 29.2.0 canvia la compatibilitat de les extensions del navegador de manera important, ja que elimina la compatibilitat amb les extensions de Firefox heretades que no s’ajusten per funcionar amb el navegador Pale Moon. Actualment, hi ha disponibles unes 230 extensions per a Pale Moon al lloc web oficial de complements Pale Moon , incloses extensions populars com Decentraleyes, uBlock Origin (Legacy) o FoxyProxy.

Segons a un missatge al fòrum de Moonchild, propietari del projecte Pale Moon, l'equip de desenvolupament sempre va considerar temporal la compatibilitat amb extensions de Firefox. És possible que les extensions clàssiques de Firefox no s’instal·lin a Pale Moon o que puguin introduir problemes de compatibilitat, i aquest és un dels motius principals per bloquejar les extensions clàssiques de Firefox a Pale Moon 29.2.0.

compatibilitat amb complements de lluna pàl·lida 29.2.0

Les extensions que no són compatibles es poden portar per fer-les compatibles amb el navegador Pale Moon, però qui ho farà? Per a l’equip del projecte Pale Moon, la resposta és clara. És la comunitat la que ha de reforçar-se per garantir que les extensions que fan servir siguin compatibles amb el navegador. Realment, la majoria dels usuaris de navegadors no saben com crear extensions de navegador ni modificar-les perquè funcionin. L’equip de Pale Moon tampoc no pot portar la majoria de les extensions del navegador al navegador, cosa que deixa a un petit grup de membres de la comunitat les habilitats i el temps per portar algunes de les extensions al navegador.

Hi ha disponible un fil al fòrum oficial de Pale Moon a publiqueu extensions crítiques només per a Firefox .

Els usuaris de Pale Moon poden romandre a la versió 29.1.1 del navegador com a mesura temporal per continuar utilitzant extensions que d’altra manera estarien desactivades a Pale Moon 29.2.0 o posterior. Una bona opció per provar la compatibilitat és utilitzar una còpia portàtil de Pale Moon 29.2.0 i provar la compatibilitat de les extensions en aquesta versió per veure quines de les extensions instal·lades continuen sent compatibles i quines no. No es recomana canviar a una versió anterior de Pale Moon després de la instal·lació de l’actualització 29.2.0, ja que pot introduir problemes de compatibilitat del perfil.

Pale Moon 29.2.0 es va llançar el 27 d'abril de 2021 .

Ara tu : feu servir Pale Moon? El canvi de compatibilitat us afecta?