El suport Thunderbird 60 i extensions

Thunderbird 60 serà la propera versió major del programa de correu electrònic d’escriptori. És un llançament principal perquè Thunderbird es mogui a una nova base de llançament de suport estès (com passa amb Firefox quan arriba la versió 60).

Thunderbird 60 inclou una interfície d'usuari actualitzada i molts altres canvis. Els usuaris de Thunderbird que executin extensions al client de correu electrònic poden afrontar problemes de compatibilitat ja que Thunderbird utilitza una política de compatibilitat estricta quan es tracta d’extensions.

En anglès : es desactivarà qualsevol extensió que no sigui explícitament compatible amb Thunderbird 60. Els intents d’instal·lar extensions de Thunderbird incompatibles estan bloquejats i els usuaris aconsegueixen que no s’hagi pogut instal·lar perquè no és compatible amb el missatge d’error de Thunderbird.

not compatible thunderbird 60

El canvi és desastrós per a l'ecosistema d'extensió de Thunderbird. Si comproveu les dues primeres pàgines d’extensions que més usuaris tenen al lloc de complements de Thunderbird, esbrinarà que en aquest moment només són compatibles vuit de les 40 extensions de Thunderbird amb més usuaris.

La situació és encara pitjor per als 40 primers complements amb millors qualificacions, ja que només cinc són compatibles amb Thunderbird 60.

Consell : podeu comprovar si les vostres extensions de Thunderbird són compatibles si visiteu Lloc de complements i cercant les extensions.

Hi ha una sortida, però, en aquest moment. L’equip de desenvolupament de Thunderbird va afegir una opció per desactivar l’execució de la verificació compatible amb l’extensió. Si bé això no significa necessàriament que les extensions funcionin si no es mostren com a compatibles, és probable que ho facin si s’han actualitzat recentment.

thunderbird extensions enable

Aquí teniu el que heu de fer per activar el commutador i desactivar la versió d’extensió estricta al client de correu electrònic:

  1. Obre el Thunderbird si no està obert ja.
  2. Toqueu la tecla Alt per mostrar el menú i seleccioneu Eines> Opcions al menú. Alternativa: feu clic a la icona de menú nova (les tres barres horitzontals) i seleccioneu les opcions quan s’obri.
  3. Canvia a la pestanya Avançada.
  4. Feu clic al botó Config Editor a General (s'obre de manera predeterminada).
  5. Confirmeu que tindreu cura.
  6. Cerqueu extensions.strictCompatibility.
  7. Feu doble clic sobre la preferència.

Un valor de veritable (per defecte) bloqueja les extensions que no figuren explícitament com a compatibles amb Thunderbird 60, un valor de fals desactiva la verificació estricta.

Thunderbird 60 està disponible com a versió beta a l’hora d’escriure. Podeu instal·lar-lo en una altra màquina o en una màquina virtual per provar les extensions que necessiteu. La nova versió del client de correu electrònic es llançarà el 15 de maig de 2018 al canal estable. Thunderbird 60 serà llançat una setmana després Firefox 60 que Mozilla té previst llançar el 9 de maig de 2018 .